Back to overview
Degraded
Polestar 4 incident
Aug 25, 2026 at 9:11am UTC
Affected services
Polestar for Fleets
Created
Aug 25, 2026 at 9:11am UTC
Polestar has an ongoing incident with Polestar 4 telemetry.
Affected services
Created
Aug 25, 2026 at 9:11am UTC
Polestar has an ongoing incident with Polestar 4 telemetry.
Affected services