Back to overview
Degraded
Issue with Stellantis Activation
Apr 13, 2026 at 8:12am UTC
Affected services
Peugeot, Citroën, DS, Opel, Vauxhall
Alfa Romeo, Fiat, Jeep
Created
Apr 13, 2026 at 8:12am UTC
Starting in late March, we observed that some vehicle activations were being rejected due to a "telematics hardware error". We raised multiple cases with the OEM, and Stellantis has confirmed the issue and is working on a fix.
According to Stellantis, the issue was resolved on April 10. We are currently monitoring vehicle activations to confirm that the problem is fully resolved.
Affected services