Back to overview
Data Interruption for Renault
May 17, 2026 at 12:44pm UTC
Affected services
Renault & Dacia For Fleets
Resolved
May 17, 2026 at 12:44pm UTC
We have observed that, since 2026-05-17 11:44:45 UTC, Renault has been unable to provide vehicle data.
Renault has confirmed the issue today and is currently working on a fix.
Update: The issue was resolved on 2026-05-18 09:04 UTC. No data was lost.
Affected services