Back to overview

Ford Fleet Clearance Paused

Apr 27 at 10:54pm CEST
Affected services
Ford for Fleets

Resolved
Apr 27 at 10:54pm CEST

All Ford fleet clearances have been paused due to an issue on the OEM side.

We have informed Ford and are awaiting their resolution of the issue.

Clearance requests will resume once the issue is resolved.

NOTE: This issue doesn't have any impact on the data delivery.

Update: Issues is resolved on 02.05.2024 08:12 UTC