Back to overview
Downtime
Interruption in BMW Data Delivery
Apr 14, 2026 at 9:26am UTC
Affected services
BMW & MINI for Fleets
Created
Apr 14, 2026 at 9:26am UTC
We have observed a drop in data delivery starting at 2026-04-14 07:33:13 UTC. We have informed the OEM and are currently awaiting their feedback.
Update 1: The issue was resolved on 14.04.2026 13:30 CEST. We have not received any confirmation by BMW.
Update 2: Starting 15.04.2026 09:40 CEST the incoming messages from BMW drop again. we are reaching the OEM to get feedback.
Affected services